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Open Source GIS  

Introduction 

In this lab, you will perform a quality control of the SimBavaria datasets you have been working with 
in ArcMap. In essence, a quality control assesses the accuracy of the digitization of a dataset. You will 
perform a QC of SimBavara by collecting points at known locations at a known scale, and compare 
these point locations to the same locations in SimBavaria. In this lab, you will be collecting the 
locations of the intersections of roads and rivers or roads and roads. You are using these locations 
because they are easy to identify in Bavaria as represented by Google Earth and SimBavaria as 
represented in QGIS. While performing the QC, you will also learn to use the open source GIS package 
QGIS and how to create a table in Microsoft Access. You will also use Google Earth to collect the point 
locations to perform the QC. 

Part 1: Collecting points in Google Earth and creating a table in Access. 

Step 1: Open Google Earth 

Step 2: Click Tools>Options>3D View 

Make sure that under “Show Lat/Long” that Universal Transverse Mercator is checked. 

Make sure that under “Show Elevation” Meters/Kilometers is selected. 

Click Okay. 

Make sure that under “View”, Toolbar, Compass, and Scale Legend are selected. 

Step 3: Open “QC_SimBavaria.kmz” layer. 

Click File>Open and navigate to the “QC_SimBavaria.kmz” layer. 

When the layer is added to Google Earth, it is added under Places>Temporary Places on the left hand 

side of the screen. 

Double-click on the first yellow thumb tack under QC_SimBavaria and Google Earth zooms to the 

location of interest.  

For each location of interest marked by a yellow thumb tack, the number represents an interstate 

number and the word next to it a river it crosses. Point “3/9” is the only point where the intersection of 

two roads is marked. 

Under “Layers” on the left-hand side of the screen, make sure the Roads, and Borders, and Places of 

Interest are selected. 
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Step 4: Start collecting points. 

 

Figure 1: Screenshot of point “3/9” in Google Earth. 

Zoom in on the first point, “3/9” to a scale where 1 inch is approximately 1000 meters, using the scale 

bar as a guide (i.e. the measurement given in the middle of the scale bar should be approximately 1000. 

Place your mouse cursor over the yellow thumb tack symbol when you are zoomed in to the appropriate 

scale. 

Then, write down the UTM coordinates of the point, which displays in the lower left hand corner of the 

screen. 

Continue until you have collected the UTM coordinates of all 10 points. 

Step 5: Create a table from your points. Skip to Page 4 if you are familiar with Access! 

Open Microsoft Access. 

Create a New Blank Database and save it to an appropriate location. 
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If Access opens a new database in the Datasheet View, change it to Design View (by clicking button 

indicated by red arrow): 

When prompted to save your table, save it as “QC_SimBavaria”. 

 

Datasheet View 

 

 

Design View 

                        

1. Type field 

names here! 

2. Then change 

the field type 

here! 

 

3. Then 

change the 

field size 

here! 

 

4. After you change the field size, you will be able to 

change the decimal places! 
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Set up your table using the following parameters (See “Design View” above for help!) 

Field Name Data Type General>Field Size General>Decimal 

Places 

Longitude (East) Number Double 2 

Latitude  (North) Number Double 2 

Description Text 50 N/A 

 

 

Figure 2: “QC_SimBavaria” in Access Table without coordinates collected from Google Earth 

Step 6: Export the Access table as a text file. 

Right click on the table name and choose Export>Text File. 

Click “Browse”. 
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Save the file to an appropriate location and name the file “QC_SimBavaria.csv”. 

The .csv stands for Comma Separated Values, a type of text file. 

Click Save and then Okay. 

The Export Text Wizard window opens. 

 

Make sure you choose Delimited. 

Click Next. 
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Make sure you choose Comma as the delimiter that separates your fields and check the box to Include 

Field Names on First Row. 

Click Next. 

Click Finish and Close. 

Deliverable 1: Screenshot of “QC_SimBavaria.csv” file opened in Excel. 
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Part 2: Introduction to QGIS and bringing SimBavaria layers into QGIS. 

Quantum GIS 0.8.1 

Introduction 

Quantum or QGIS is an open source desktop geographic information system. It can be downloaded from 
http://download.qgis.org/qgis/index_0_8_1.html. The version installed on the computers, 0.8.1, is the 
most stable current release as of November 2007. 
 
Step 1: Start QGIS. 

Double-click the icon on the desktop or navigate to Start > All Programs > Quantum GIS. 

The GUI or Graphical User Interface displays. 

 

Figure 1. Quantum GIS 0.8.1 running with toolbars displayed. 

Like ArcMap, QGIS displays with the Toolbars running across the top of the screen, a Map Window pane 
on the right-hand side of the screen, and a Legend/Layers pane on the left hand-side of the screen. 
Unlike ArcMap, the QGIS Graphical User Interface also includes an Overview Map Window, located 
directly beneath the Legend window.  
 
The Map Overview Window provides a full extent view of layers added to it. Within the view is a 
rectangle showing the current map extent. This allows you to quickly determine which area of the map 
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you are currently viewing. You can add a single layer to the overview by right-clicking on it in the legend 
and choosing “Add to overview”. You can also add or remove all layers to the overview using the 
Overview tools on the toolbar. You can also grab the red rectangle showing your current extent and pan 
around; the map view will update accordingly. 
 

 
 
Figure 2. Simbavaria districts in Map View of QGIS, with zoomed in position indicated by red box in Map 

Overview Window. 
 
If you open QGIS and you do not have the toolbars shown in Figures 1 and 2, it may be because the 
toolbars are not turned on or plug-ins have not been activated. 
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Step 2: Display tools. 

To turn on the toolbars, go to View > Toolbars> Show Most Toolbars . 

To activate the plug-ins, go to Plugin > Plugin Manager. 

The QGIS Plugin Manager display box opens. 

 

Figure 3. QGIS Plugin Manager. 

On the left-hand side of the Plugin Manager, under “Name”, check the boxes for North Arrow and Scale 
Bar. Click Ok.  

Notice that the north arrow has been added to the Map Window and the scale now displays.  

Also like ArcMap, you can rearrange the position of the toolbars.  Simply click the left-hand side of the 
toolbar, where a vertical line of alternating dots are located or two black arrows, and drag the toolbar to 
the desired position.  

Step 3: Convert feature classes in Simbavaria geodatabase into shapefiles. 

Unfortunately, QGIS does not recognize the feature classes stored in personal geodatabases, only 
shapefiles. Therefore, you must create shapefiles before you can load them to QGIS. 

Start ArcCatalog. Navigate to where your SimBavaria personal geodatabase is located.  
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In order to create shapefiles from feature classes stored in a personal geodatabase, you must first create 
a new folder to which you will store the shapefiles you are about to create. Choose a location where you 
would like to store the shapefiles and then right mouse-click New > Folder. Name the folder 
“QC_SimBavaria”.  

Display ArcToolbox. Go to Conversion Tools > To Shapefile>Feature Class to Shapefile (multiple). 

 

Figure 4. Feature Class to Shapefile tool display window. 

Add the districts, rivers, cities, and roads layers.  

For the Output Folder location, navigate to your “QC_SimBavaria” folder and click Add. 

Click Okay in the Feature Class to Shapefile window.  

Close the status box when the tool has finished running. 

Using the Feature Class to Shapefile conversion tool has created a single shapefile for each 

corresponding feature class. 
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Step 4: Add shapefiles to QGIS.  

In QGIS, either go to Layer > Add Vector Layer from the Menu bar or click the Add a Vector Layer button 

directly from the toolbar (The button is a graphic of a plus sign over a vector layer).  

The “Open an OGR Supported Vector Layer” window opens.  

 

Figure 5. Add a vector layer to QGIS. 

Use either the “Look in” drop down menu or double-click on “My Computer” to navigate to your 

“Simbavaria_Shapefiles” folder. 

Add the districts, roads, rivers, and cities SimBavaria shapefiles to QGIS. 
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Figure 6. SimBavaria in QGIS.  

Notice that the graphic scale bar displays in the upper-right or left hand corner of the Map Window, and 

that the map scale displays at the lower-right hand corner of the Map Window. To change the position 

of the graphic scale bar, go to Plugins>Decorations>Scale Bar. 

To arrange layers within the Legend, simply click and drag layers. Arrange the layers in the following 

order: Roads, Rivers, Cities, and Districts. 
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Step 5: Examine the map properties. 

From the main menu, select Settings > Project Properties.  

 

Figure 7. Project Properties window in QGIS. 

Make sure the General tab is selected. 

Notice that under Map Units, Meters is selected. If you were to change the Map Units in the Project 

Properties, it would be reflected in the ratio and verbal scales, as well as the Map Coordinates at Mouse 

Position display box (located next to the map scale at the bottom right-hand corner side of the Graphical 

User Interface). 

In the Project Properties window, click the Projection tab. 

Under “Spatial Reference System”, make sure that WGS 84 is selected from Geographic Coordinate 

Systems (Id 2585). Click OK to close the Project Properties. WGS 84 should be highlighted in a darker 

shade of gray and should appear in the white box below the list of spatial reference systems. 
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Step 6: Change the symbology. 

Changing a feature’s symbology in QGIS is very similar to changing it in ArcMap. Simply right-click on the 

feature’s name and chose Properties and Symbology. 

 

Figure 8. Symbology Selector for a Vector Layer in QGIS. 

Change the color of the districts to a brown, the cities purple, rivers to a dark blue, and roads to black. 

Also, make sure the outline width of the roads and rivers are 2. 
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Step 7: Examine the metadata and attribute tables for the features. 

Right-click on Cities and choose Properties. Notice that the Properties window for the Cities layer 

includes a Metadata Tab. 

 

Figure 9. Metadata for SimBavaria’s “Cities” layer in QGIS. 

Unlike ArcMap, you cannot access the attribute table for a layer by right clicking on the layer. In QGIS, 

you must access the attribute table for a layer from the toolbars, or by clicking on the Open Table 

button from the main toolbars. 

If you hover over a button with clicking and then look in the lower left-hand side of the screen, QGIS will 

display the tool’s name. 
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Make sure “Districts” is selected and then click the “Open Table” button from the toolbar. 

 

 

The attribute table for the Districts layer opens. 

 

Figure 10. Attribute table for the Simbavaria “Districts” layer in QGIS. 

Attribute tables in QGIS are similar to those in ArcMap with columns containing attribute fields and rows 

containing the individual records. 

You are now ready to add your x,y coordinates from Google Earth to QGIS. 

Step 8: Add a Delimited Text Layer 

Go to Plugins>Plugin Manager. 

Make sure “Add Delimited Text Layer” and “ScaleBar” are selected. 

Click Ok. 

Click the “Add Delimited Text Layer” button. 

 

The “open 

table” button! 

The “add 

delimited text 

layer” button! 
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When the “Create a Layer from a Delimited Text File” opens, make sure you choose your 

“QC_SimBavaria.csv”.  

Make sure that the Delimiter field contains a comma (add one if it doesn’t!) as this is the character that 

separates your latitude and longitude values.  

Click Parse. 

In the X field, make sure you choose Longitude. 

In the Y field, make sure you choose Latitude. 

Click Add Layer. 

This is one way of getting x and y coordinates into QGIS. 

Leave QGIS open and the layers added and symbolized according to the previous steps for the next part 

of the assignment. 

 

Figure 12: SimBavaria layers and Google Earth coordinates in QGIS. 

Deliverable 2: Screenshot of SimBavaria and Google Earth coordinates in QGIS (See Figure 12 above). 
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Part 3: Collecting coordinates and creating a map layout in QGIS. 

Step 1: Open the attribute table for “QC_SimBavaria”. 

Add each layer found in the Table of Contents to the Overview Map Window by right clicking on each 

layer and selecting to “Add to Overview”. 

Then, open the attribute table for the “QC_SimBavaria” points. 

Arrange the attribute table so you can see most of the QGIS map display. 

Click on a point in the attribute table and notice that the point is highlighted in the map display. If the 

point is not highlighted, make sure the appropriate layer is selected in the Table of Contents. 

Step 2: Zoom in on the selected feature. 

Zoom in to the first point. Does the point from Google Earth line up correctly with its location as 

displayed in QGIS? What is a possible reason for this distortion? Consider the source of the original 

SimBavaria datasets and issues of scale and accuracy of digitization. Note: both QGIS and Google Earth 

are Geographic Coordinate Systems, UTM WGS 1984. 

Zoom in to the location of where the point from Google Earth should be displayed in QGIS. Again, make 

sure the scale is approximately 1: 1000 meters. 

Deliverable 3: Answer to questions. 

Step 3: Open “QC_SimBavaria” Access Table and add coordinates from QGIS. 

Open the “QC_SimBavaria” Access Table you created previously and, in the design view, add 2 more 

fields:  

Field Name Data Type General>Field Size General>Decimal 

Places 

Lon_QGIS Number Double 2 

Lat_QGIS Number Double 2 

 

Be sure to resave the table to an appropriate location. 

Create a new vector layer in QGIS by going to Layer>New Vector Layer. 

Name and Save the layer to an appropriate location. 

Right click on the layer and select “Allow Editing” to allow digitizing. 
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Record the position of where the roads and rivers actually cross in QGIS at a scale of approximately 
1:1000 meters (the same scale used in Google Earth) using the “Capture Point” button from the toolbar 
and left-clicking to digitize the point feature.  
 
The attribute window will appear, allowing you to enter the information for the new feature.  Add a 
Description field and use the descriptions you typed for the points taken from Google Earth so you don’t 
confuse the points! Click Okay and continue digitizing until you have recorded all 10 points. 
 
If you make a mistake, select the feature using the tool with the hand icon (or select the feature row in 
the attribute table to highlight it) and then hit the button with the scissors icon. 
 
When you are finished, right click the layer and deselect “Allow Editing” and save the changes to the 
layer. 
 
 
 

 
Figure 1: Digitizing in QGIS. 

 

 
 
 

Capture point 

button! 

Place point where 

rivers and roads 

intersect in QGIS! This 

point will be added to 

the new vector layer! 

 
Coordinates 

collected from 

Google Earth! 
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Figure 2: QGIS with digitized points and points taken from Google Earth. River and road names added to 
help guide digitizing only. 

 
Then, hover over the point with your cursor and using the coordinates given in the lower-right hand 
corner of the QGIS map display, record the coordinates in the Access table. Make sure you are zoomed 
in to a scale of 1:1000 meters or the coordinates will be inaccurate! 

BE SURE TO ENTER THE POINTS FROM QGIS INTO ACCESS IN THE ORDER THAT THEY WERE RECORDED IN 
GOOGLE EARTH. 
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Figure 3: Access with final formatting 

Step 4: Prepare a final map layout 

The districts, cities, rivers, and roads should already be symbolized appropriately. 

However, the two point layers must be symbolized. 

Make the points taken from Google Earth a bright green color with a symbol size of 6. Make the points 
digitized in QGIS a bright red with a symbol size of 6. 

Now you are ready to create a final map layout. 

Zoom to the layer extent of the Districts in the Map View (right click on layer to access this option) 
before accessing the Print Composer. 

To access the Print Composer, click on the Print button in the toolbar or choose Print from the File 
Menu. 
 
The Map Composer has two tabs: “General” and “Item”. The “General” tab allows you to set the paper 
size, orientation, and resolution for the map. The “Item” tab displays the properties for the currently 
selected map element. By selecting an element on the map (eg. legend, scalebar, text, etc.) and 
clicking on the “Item” tab, you can customize the settings. 
 
To add the QGIS map canvas to the map composer, click on the “Add a new map” button in the 
Toolbar of the Print Composer window.  
 
Drag a rectangle (IMPORTANT: start in the upper-left hand corner and drag outwards to the lower-right 
hand corner so that the map frame is almost as large as the paper) on the composer canvas to add the 
map. You can resize the map later by clicking on the “Select/move item” button, clicking on the map, 
and dragging one of the handles in the corner of the map. With the map selected, you can also resize 
the map by specifying the width and height on the Item properties tab. 
 
 
A legend can be added to the composer canvas and customized to show only the desired layers. 
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To add a legend, click on the “Add Vector Legend” button. The legend will be placed on the composer 
canvas and you can move it where you like. Click on the “Items” tab to customize the appearance of 
the legend, including which layers are shown. 
 

Once you have added a legend and scale bar you are finished! 

Note: try adjusting the font is your legend and scale bar appear distorted! 

 

Figure 4: Layout view of SimBavaria in QGIS. 

Deliverable 4: Final map layout with layers added, arranged, and symbolized according to instructions 

on pages 14 and 22. 

Deliverable 5: Digital copy of final Access table with coordinates taken from Google Earth and QGIS 

(See Figure 3 on page 22). 


